Internet Explorer 8 Users Need to Upgrade!

ScienceDirect, one of our major providers of electronic journals, will no longer support Internet Explorer 8 and previous versions as of January 1, 2016. If you use IE8 or an older version, please upgrade now.

For the optimum user experience, we recommend that you move away from any older browser versions to current versions of IE, Firefox, or Chrome.

Category: 
Tags: